Linux slogan
Visite também: BR-Linux.org · Dicas-L · SoftwareLivre.org · UnderLinux



» Screenshot

Comunidades

Servidor playsms [RESOLVIDO]

[1] Enviado em 05/06/2012 - 15:44h Servidor playsms [RESOLVIDO]
Linux user: Alexandre Monteiro
alexandrevl

(usa Debian)


Boa tarde 'pessoal'
Tive muita dificudade para deixar o servidor Playsms funcionado.
#SERVIDOR DE ENVIO DE SMS EM MASSA, ATRAVES DO SEU CELULAR OU MODEM.

###VOU POSTAR UM TUTORIAL. COM DETALHES.Logon and active root account:

#UBUNTU / DEBIAN


1/NO TERMINAL COMO ROOT.
---------------------------------------------------------------------
apt-get update
apt-get upgrade -y
---------------------------------------------------------------------


2/- Install Playsms:

Logon com raiz e instalar alguns softwares:

#TERMINAL
---------------------------------------------------------------------
apt-get install -y apache2 mysql-server php5 php5-cli php5-cgi php-pear php-db phpmyadmin libapache2-mod-php5 gcc sendmail
---------------------------------------------------------------------
Quando a caixa de solicitar a senha, eu escolho 111111 para todos.

#obs. -y é para afirmar yes em todas instalaçoes


#TERMINAL
---------------------------------------------------------------------
adduser playsms
---------------------------------------------------------------------


Criar playSMS raiz da web, carretel e registrar e definir a propriedade para o usuário www-data:

#TERMINAL Code: CRIE OS SEGUINTES DIRETORIOS
---------------------------------------------------------------------
mkdir -p /var/www/playsms
mkdir -p /var/spool/playsms
mkdir -p /var/log/playsms
chown -R www-data /var/www/playsms
chown -R www-data /var/spool/playsms
chown -R www-data /var/log/playsms
Download Playsms:
---------------------------------------------------------------------

NA PASTA EM QUE TIVER BAIXE.

---------------------------------------------------------------------
wget http://biznetnetworks.dl.sourceforge.net/project/playsms/playsms/Version%200.9.5.1/playsms-0.9.5.1.tar.gz
---------------------------------------------------------------------


Unzip: NA MESMA PASTA

#COMANDO
---------------------------------------------------------------------
tar -zxvf playsms-0.9.5.1.tar.gz -C /usr/local/src
---------------------------------------------------------------------

O unzip ira descopactar dentro de /usr/local/src

TERMINAL:
---------------------------------------------------------------------
cd /usr/local/src/playsms-0.9.5.1/web
cp -rR * /var/www/playsms
chown -R www-data /var/www/playsms
---------------------------------------------------------------------

INSTALANDO BANCO DE DADOS:

TERMINAL:
---------------------------------------------------------------------
mysqladmin -u root -p create playsms
---------------------------------------------------------------------
Quando a caixa de pedir tipo de senha,: 111111, em seguida, pressione Enter.

TERMINAL:
---------------------------------------------------------------------
mysql -u root -p playsms < /usr/local/src/playsms-0.9.5.1/db/playsms.sql
---------------------------------------------------------------------
Quando a caixa de pedir tipo de senha,: 111111 e pressione Enter.

###
Copiar config-dist.php para config.php e editar config.php:

TERMINAL:
---------------------------------------------------------------------
cd /var/www/playsms
cp config-dist.php config.php
---------------------------------------------------------------------
Preencha campo obrigatório com contious no arquivo config.php:

terminal:
---------------------------------------------------------------------
vim config.php
---------------------------------------------------------------------
Por favor, encontrar rootpassword (na linha 8) e substituir por 111111 em seguida, salvar e sair.
######
OBS. EU USO VIM, VOCE PODERA USAR O EDITOR DE SUA PREFERENCIA.

ENTRE NO DIRETORIO E EXECUTE A CP

Code:
---------------------------------------------------------------------
cd /usr/local/src/playsms-0.9.5.1/bin
cp playsmsd playsmsd.php playsmsd_start /usr/local/bin/
cp playsms /etc/default/
---------------------------------------------------------------------
Faça playsmsd_start será iniciado automaticamente no boot:
TERMINAL:
---------------------------------------------------------------------
vim /etc/init.d/rc.local
---------------------------------------------------------------------

Adicionar quote abaixo no final do arquivo (antes de sair se há comando de saída), em seguida, salvar e sair:
#######################

#adicionar linha
/usr/local/bin/playsmsd_start

#######################

smstools3 é o que agente ira usar para gateway via celular.

3/- Install Smstools3:

Download Smstools3:

##terminal:
---------------------------------------------------------------------
wget http://smstools3.kekekasvi.com/packages/smstools3-3.1.14.tar.gz
---------------------------------------------------------------------
Unzip:

##terminal: NO MESMO DIRETORIO QUE VOCE BAIXOU
---------------------------------------------------------------------
tar -zxvf smstools3-3.1.14.tar.gz -C /usr/local/src
---------------------------------------------------------------------

Installing smstools3:

Code:
---------------------------------------------------------------------
cd /usr/local/src/smstools3
make
make install
---------------------------------------------------------------------
Voltar ao playSMS diretório de origem, smsd.conf cópia da contrib / smstools / para / etc:

TERMINAL:
---------------------------------------------------------------------
cd /usr/local/src/playsms-0.9.5.1
cp contrib/smstools/smsd.conf /etc/
---------------------------------------------------------------------

PLUGUE O CELULAR NA USB DE PREFERENCIA NAS TRAZEIRAS.

#TERMINAL FAÇA:
---------------------------------------------------------------------
lsusb
---------------------------------------------------------------------
NO MEU CASO LISTOU ASSIM:

REPARE SE APARECEU Phone. se sim dectou se aparelho ok.

Quote:
Bus 008 Device 002: ID 22b8:4902 Motorola PCS Triplet GSM Phone (AT)
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Findown where usb port cellphone use:

### TERMINAL:
---------------------------------------------------------------------
ls /dev/tty*
---------------------------------------------------------------------
REPARE NO ACMO - tty,do seu aparelho

Quote:
/dev/tty /dev/tty19 /dev/tty3 /dev/tty40 /dev/tty51 /dev/tty62
/dev/tty0 /dev/tty2 /dev/tty30 /dev/tty41 /dev/tty52 /dev/tty63
/dev/tty1 /dev/tty20 /dev/tty31 /dev/tty42 /dev/tty53 /dev/tty7
/dev/tty10 /dev/tty21 /dev/tty32 /dev/tty43 /dev/tty54 /dev/tty8
/dev/tty11 /dev/tty22 /dev/tty33 /dev/tty44 /dev/tty55 /dev/tty9
/dev/tty12 /dev/tty23 /dev/tty34 /dev/tty45 /dev/tty56 /dev/ttyACM0
/dev/tty13 /dev/tty24 /dev/tty35 /dev/tty46 /dev/tty57 /dev/ttyS0
/dev/tty14 /dev/tty25 /dev/tty36 /dev/tty47 /dev/tty58 /dev/ttyS1
/dev/tty15 /dev/tty26 /dev/tty37 /dev/tty48 /dev/tty59 /dev/ttyS2
/dev/tty16 /dev/tty27 /dev/tty38 /dev/tty49 /dev/tty6 /dev/ttyS3
/dev/tty17 /dev/tty28 /dev/tty39 /dev/tty5 /dev/tty60
/dev/tty18 /dev/tty29 /dev/tty4 /dev/tty50 /dev/tty61
Config smsd.conf:

##terminal:
---------------------------------------------------------------------
vim /etc/smsd.conf
---------------------------------------------------------------------
Por favor, encontrar ttyUSB0 (na linha 27) e substituir com ttyACM0 em seguida, salvar e sair.

Criar alguns diretórios importantes para smstools3:

##terminal:
---------------------------------------------------------------------
mkdir -p /var/spool/sms/checked
mkdir -p /var/spool/sms/failed
mkdir -p /var/spool/sms/incoming
mkdir -p /var/spool/sms/outgoing
mkdir -p /var/spool/sms/sent
mkdir -p /var/log/sms
---------------------------------------------------------------------
Alterar permissões em alguns diretórios para que o usuário do servidor web possa escrever arquivos nele:

#terminal:
---------------------------------------------------------------------
chown -R www-data /var/spool/sms
---------------------------------------------------------------------

Para o smstools3 ser executado automaticamente a cada inicialização, digite o seguinte comando:

#terminal:
--------------------------------------------------------------------
update-rc.d sms3 defaults
--------------------------------------------------------------------
Reboot servidor:

##Terminal:
--------------------------------------------------------------------
reboot
--------------------------------------------------------------------

ESPERO TE AJUDADO, AKI FUNCIONOU CERTINHO.

Att Alexandre Monteiro.

 

  


[2] Enviado em 10/06/2012 - 10:04h OBRIGADO
Linux user: Alexandre Monteiro
alexandrevl

(usa Debian)


Amigo abrigado pela dica, ja criei. abrçs.

 

[3] Enviado em 06/07/2012 - 22:24h Re: Servidor playsms [RESOLVIDO]
Linux user: Junior
dompj

(usa Ubuntu)


Olá!
Tudo bem?

Será que podia me ajudar, por favor?
Tentei com meu Iphone e também com um Motorola ...

Apesar de identificarem no lsusb nenhum é listado no tty ...
Alguma ideia? ;)

Abraços e obrigado!

 

[4] Enviado em 06/07/2012 - 22:52h Re: Servidor playsms [RESOLVIDO]
Linux user: Alexandre Monteiro
alexandrevl

(usa Debian)


Ola amigo cola aki o que aparece no lsusb, e no ls /dev/tty*


 

[5] Enviado em 07/07/2012 - 16:20h Re: Servidor playsms [RESOLVIDO]
Linux user: Junior
dompj

(usa Ubuntu)


Olá!
Obrigado pela sua resposta ...

Tentei com outro celular (Xing-ling) e consegui achar o ttyACM0 ...
Mas não estou tendo sucesso em enviar SMS ou receber ...

Os envios ficam apenas como "Pendente" e os recebimentos nem aparecem ..
Alguma luz? ;)

Abraços e obrigado!
______

Quando eu mando uma mensagem para o celular, ela chega no aparelho, mas não aparece no SMSTools ...

____________________

Instalei tudo do zero, exatamente como você ...
O celular foi identificado corretamente, configurei o ACM0 ...
Mas nada de funcionar, nem pelo SMStools e nem pelo terminal direto.

Mesmo tentando "sendsms numero mensagem" ele via ...
Já tentei colocar o número como +5511xxxxxxx só 11xxxxx só o telefone ...
De todo jeito não vai ... nem mesmo gasta crédito do celular ...

Estou testando com um V3 na Claro ...

Peço mesmo sua ajuda, porque não sei mais o que fazer e pelo jeito, você tem o seu funcionando.

Obrigado!

____________________________________________________________

Consegui fazer enviar =)
Tanto pelo SMSTOols quanto pelo terminal mesmo ;)
Troquei o aparelho e foi de boa ;)

Valeu! =)
Vou testar por aqui ;)

 

[6] Enviado em 12/07/2012 - 23:13h Ajuda
Linux user: Lucas Demetrius Carvalho de Jesus
LucasDemetrius

(usa Debian)


Amigo eu consegui instalar, muito massa sua dica
porém quando abro o navegador e envio um sms não envia fica apenas pendente
onde configuro o meu celular
Sansung Galaxy S2 tem como funcionar?

Att.
Lucas

 

[7] Enviado em 13/07/2012 - 10:10h Re: Servidor playsms [RESOLVIDO]
Linux user: Alexandre Monteiro
alexandrevl

(usa Debian)


Bom dia Lucas.
Por favor mostre os dispositivos conectados a usb..
comand >>> #lsusb
e
tambem >>> # ls /dev/tty*

OBS:
Com o Dispotivo samsung conectado..

 

[8] Enviado em 24/07/2012 - 17:01h Modem 3g
Linux user: Daniel Bressan
bressan

(usa Debian)


Olá amigo, estou tentando configurar o servidor playsms, seguindo os passos por ti explicado. Mas não consigo enviar mensagens. Tentei com 2 modens 3g um Olivetti da Tim e Outro Huawei, ambos são detectados tudo certinho. Mas quando mando enviar as mensagens ela ficam como pendente e nao sao enviadas. testei os modens tentando conectar pelo wvdial, e eles conectam perfeitamente. O que eu precebi é que qaundo eu inicio o sms3, o modem não se conecta. fica como se estivesse desconectado.
Poderia me dar uma ajuda

Agradeço.

 

[9] Enviado em 24/07/2012 - 18:25h Re: Servidor playsms [RESOLVIDO]
Linux user: Alexandre Monteiro
alexandrevl

(usa Debian)


bressan escreveu:

Olá amigo, estou tentando configurar o servidor playsms, seguindo os passos por ti explicado. Mas não consigo enviar mensagens. Tentei com 2 modens 3g um Olivetti da Tim e Outro Huawei, ambos são detectados tudo certinho. Mas quando mando enviar as mensagens ela ficam como pendente e nao sao enviadas. testei os modens tentando conectar pelo wvdial, e eles conectam perfeitamente. O que eu precebi é que qaundo eu inicio o sms3, o modem não se conecta. fica como se estivesse desconectado.
Poderia me dar uma ajuda

Agradeço.




Ola amigo, Bressan..
Quando voce visualiza a lista no dev/tty >> esta aparecendo USB ?? 0,1,2,3
aguardo sua resposta..

 

[10] Enviado em 24/07/2012 - 19:20h Re: Servidor playsms [RESOLVIDO]
Linux user: Daniel Bressan
bressan

(usa Debian)


alexandrevl escreveu:

bressan escreveu:

Olá amigo, estou tentando configurar o servidor playsms, seguindo os passos por ti explicado. Mas não consigo enviar mensagens. Tentei com 2 modens 3g um Olivetti da Tim e Outro Huawei, ambos são detectados tudo certinho. Mas quando mando enviar as mensagens ela ficam como pendente e nao sao enviadas. testei os modens tentando conectar pelo wvdial, e eles conectam perfeitamente. O que eu precebi é que qaundo eu inicio o sms3, o modem não se conecta. fica como se estivesse desconectado.
Poderia me dar uma ajuda

Agradeço.




Ola amigo, Bressan..
Quando voce visualiza a lista no dev/tty >> esta aparecendo USB ?? 0,1,2,3
aguardo sua resposta..


olá

Com o Huawei parece TTYUSB0 e TTYUSB1 e com o olivetti nao aparece nada, mas se dou o comando lsusb mostra o oliveti e o Huawei

 

[11] Enviado em 25/07/2012 - 09:35h Re: Servidor playsms [RESOLVIDO]
Linux user: Alexandre Monteiro
alexandrevl

(usa Debian)


bressan escreveu:

alexandrevl escreveu:

bressan escreveu:

Olá amigo, estou tentando configurar o servidor playsms, seguindo os passos por ti explicado. Mas não consigo enviar mensagens. Tentei com 2 modens 3g um Olivetti da Tim e Outro Huawei, ambos são detectados tudo certinho. Mas quando mando enviar as mensagens ela ficam como pendente e nao sao enviadas. testei os modens tentando conectar pelo wvdial, e eles conectam perfeitamente. O que eu precebi é que qaundo eu inicio o sms3, o modem não se conecta. fica como se estivesse desconectado.
Poderia me dar uma ajuda

Agradeço.




Ola amigo, Bressan..
Quando voce visualiza a lista no dev/tty >> esta aparecendo USB ?? 0,1,2,3
aguardo sua resposta..


olá

Com o Huawei parece TTYUSB0 e TTYUSB1 e com o olivetti nao aparece nada, mas se dou o comando lsusb mostra o oliveti e o Huawei




Amigo .. ja entendi oque esta acontecendo.. sigua esses paços de um outro parceiro..
para fixar seu modem usb , como COM.

http://www.vivaolinux.com.br/artigo/Passos-essenciais-para-configurar-seu-modem-3G-no-Linux/?pagina=3

 

[12] Enviado em 10/09/2012 - 10:56h nao consegui
Linux user: lucas
lucasfsalomao

(usa Outra)


Amigo ja tentei tudinho nao conseguir ja coloquei modem me ajuda por remoto lucasfsalomao@hotmail.com add ai


 

  
<< Primeira | Anterior Próxima | Última >>
Responsável pelo site: Fábio Berbert de Paula - Conteúdo distribuído sob licença GNU FDL
Site hospedado por:

Viva o Linux

A maior comunidade Linux da América Latina! Artigos, dicas, tutoriais, fórum, scripts e muito mais. Ideal para quem busca auto-ajuda em Linux.