.
Estou utilizando a porta padrão 7200, se esta for mudada, também deverá ser mudada no arquivo .net.
E deveremos iniciar nossa topologia com o Dynagen.
Como instalamos o Dynagen com seu tarball, pois pelo apt não funcionou, então devemos apontar o arquivo manualmente:
Como eu não especifiquei no arquivo .net anteriormente, a porta console de cada equipamento abriu uma porta em seu localhost da forma padrão, segue a lista.
Agora seguem as configurações já prontas para todo o ambiente se falar, mas esse é só um exemplo, todos poderão personalizar seu ambiente, ativar protocolos etc.
SW1#sh run
Building configuration...
Current configuration : 2488 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname SW1
boot-start-marker
boot-end-marker
enable secret 5 $1$ZIgp$B4w0lvzqbTeF2t6IWwNor0
no aaa new-model
ip subnet-zero
interface FastEthernet0/0
no ip address
shutdown
interface FastEthernet0/1
description vlan 10 go to RT1
switchport access vlan 10
no ip address
duplex full
speed 100
interface FastEthernet0/2
description vlan 20 go to RT2
switchport access vlan 20
no ip address
duplex full
speed 100
interface FastEthernet0/3
no ip address
shutdown
interface FastEthernet0/4
no ip address
shutdown
interface FastEthernet0/5
no ip address
shutdown
interface FastEthernet0/6
no ip address
shutdown
interface FastEthernet0/7
no ip address
shutdown
interface FastEthernet0/8
no ip address
shutdown
interface FastEthernet0/9
no ip address
shutdown
interface FastEthernet0/10
description Porta Trunk Router on stick
Linux
switchport mode trunk
no ip address
interface FastEthernet0/11
no ip address
shutdown
interface FastEthernet0/12
description Porta trunk
switchport mode trunk
no ip address
duplex full
speed 100
interface FastEthernet0/13
no ip address
shutdown
interface FastEthernet0/14
no ip address
shutdown
interface FastEthernet0/15
no ip address
shutdown
interface Vlan1
no ip address
shutdown
interface Vlan10
description Vlan10 RT1 e RT3
ip address 192.168.10.100 255.255.255.0
lan-name Vlan10
interface Vlan20
description Vlan20 RT2 e RT4
ip address 192.168.20.100 255.255.255.0
lan-name Vlan20
ip http server
ip classless
line con 0
password cisco
login
line aux 0
line vty 0 1
password cisco
login
line vty 2 4
login
end
SW1#
SW2#sh run
Building configuration...
Current configuration : 2414 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname SW2
boot-start-marker
boot-end-marker
enable secret 5 $1$Ee9s$AFbrTN5bLqpblkULAV92c/
no aaa new-model
ip subnet-zero
interface FastEthernet0/0
no ip address
shutdown
interface FastEthernet0/1
description Vlan 10 go to RT3
switchport access vlan 10
no ip address
duplex full
speed 100
interface FastEthernet0/2
description Vlan 20 go to RT4
switchport access vlan 20
no ip address
duplex full
speed 100
interface FastEthernet0/3
no ip address
shutdown
interface FastEthernet0/4
no ip address
shutdown
interface FastEthernet0/5
no ip address
shutdown
interface FastEthernet0/6
no ip address
shutdown
interface FastEthernet0/7
no ip address
shutdown
interface FastEthernet0/8
no ip address
shutdown
interface FastEthernet0/9
no ip address
shutdown
interface FastEthernet0/10
no ip address
shutdown
interface FastEthernet0/11
no ip address
shutdown
interface FastEthernet0/12
description Porta Trunk
switchport mode trunk
no ip address
duplex full
speed 100
interface FastEthernet0/13
no ip address
shutdown
interface FastEthernet0/14
no ip address
shutdown
interface FastEthernet0/15
no ip address
shutdown
interface Vlan1
no ip address
shutdown
interface Vlan10
description Vlan 10
ip address 192.168.10.101 255.255.255.0
lan-name Vlan10
interface Vlan20
description Vlan 20
ip address 192.168.20.101 255.255.255.0
lan-name Vlan20
ip http server
ip classless
line con 0
password cisco
login
line aux 0
line vty 0 1
password cisco
login
line vty 2 4
login
end
SW2#
RT1#sh run
Building configuration...
Current configuration : 1289 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname RT1
boot-start-marker
boot-end-marker
enable secret 5 $1$oH2g$3Z2gdf0Vkn./w0OfgUoFR1
no aaa new-model
ip subnet-zero
interface FastEthernet0/0
description Vlan 10 go to SW1
ip address 192.168.10.1 255.255.255.0
speed 100
full-duplex
ip http server
ip classless
ip route 192.168.20.0 255.255.255.0 192.168.10.254
line con 0
password cisco
login
line aux 0
line vty 0 1
password cisco
login
line vty 2 4
login
end
RT1#
RT2#sh run
Building configuration...
Current configuration : 1289 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname RT2
boot-start-marker
boot-end-marker
enable secret 5 $1$/x.q$tEjWEahasLjxp0G2aTFUT.
no aaa new-model
ip subnet-zero
interface FastEthernet0/0
description Vlan 20 go to SW1
ip address 192.168.20.2 255.255.255.0
speed 100
full-duplex
ip http server
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.20.254
line con 0
password cisco
login
line aux 0
line vty 0 1
password cisco
login
line vty 2 4
login
end
RT2#
RT3#sh run
Building configuration...
Current configuration : 1289 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname RT3
boot-start-marker
boot-end-marker
enable secret 5 $1$Z50x$itE38bSPV.ObBKZBKBd3h.
no aaa new-model
ip subnet-zero
interface FastEthernet0/0
description Vlan 10 go to SW2
ip address 192.168.10.3 255.255.255.0
speed 100
full-duplex
ip http server
ip classless
ip route 192.168.20.0 255.255.255.0 192.168.10.254
line con 0
password cisco
login
line aux 0
line vty 0 1
password cisco
login
line vty 2 4
login
end
RT3#
RT4#sh run
Building configuration...
Current configuration : 1289 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname RT4
boot-start-marker
boot-end-marker
enable secret 5 $1$ye/.$r19lOHRw9zOOEuHcSif530
no aaa new-model
ip subnet-zero
interface FastEthernet0/0
description Vlan 20 go to SW2
ip address 192.168.20.4 255.255.255.0
speed 100
full-duplex
ip http server
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.20.254
line con 0
password cisco
login
line aux 0
line vty 0 1
password cisco
login
line vty 2 4
login
end
RT4#
Neste momento as Vlans não se falam, vamos habilitar o roteamento na nossa máquina Linux.