brunoalvesinfra
(usa Ubuntu)
Enviado em 31/08/2023 - 07:59h
Tenho esse script abaixo na minha RB750Gr3 com três link porem quando o link principal cai o mesmo não pega o link de backup pois ele esta apontado para a interface ether01 que é pppoe-cliente01, alguém poderia me ajudar para pega os outros link quando a principal cair, sendo o link pppoe-cliente01 / pppoe-cliente02 e roteador na dmz.
# Coloque seu usuario e senha
:local noipuser "br_alves"
:local noippass "201848ars"
:local noiphost "infonet.ddns.net"
# Coloque a interface que recebe o link
:local inetinterface "pppoe-cliente01"
#------------------------------------------------------------------------------------
# Nao precisa mexer
:global previousIP
:if ([/interface get $inetinterface value-name=running]) do={
# Ele pega o IP atual na interface
:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]
# Retira a máscara da rede do endereço IP
:for i from=( [:len $currentIP] - 1) to=0 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:if ($currentIP != $previousIP) do={
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
:set previousIP $currentIP
# Pega a URL da atualização.
:local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info "No-IP: Sending update for $host"
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
# Coloque abaixo emtre aspas o seu host do no-ip.
:log info "mauriciomk.ddns.net"
}
} else={
:log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
}
} else={
:log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}